:::: MENU ::::

Redmineのインストール

Pocket

Redmineのインストール手順

tracより簡単だわ。tracが難しすぎるってのもあるけど。

rubyのインストール

#  yum install gcc-c++.x86_64 patch.x86_64 openssl-devel.x86_64 readline-devel.x86_64 zlib-devel.x86_64 curl-devel.x86_64
#  wget http://rubyenterpriseedition.googlecode.com/files/ruby-enterprise-1.8.7-2011.03.tar.gz
#  tar xvfz ruby-enterprise-1.8.7-2011.03.tar.gz 
#  cd ruby-enterprise-1.8.7-2011.03
#  ./installer

rubygemのインストール

#  wget http://production.cf.rubygems.org/rubygems/rubygems-1.8.10.tgz
#  tar xvfz rubygems-1.8.10.tgz 
#  cd rubygems-1.8.10
#  ruby setup.rb 

redmineのインストール

#  gem install rack -v=1.1.1 --no-rdoc --no-ri
#  gem install rake -v=0.8.7 --no-rdoc --no-ri
#  gem install i18n -v=0.4.2 --no-rdoc --no-ri
#  gem install mysql --no-rdoc --no-ri
#  gem install rails -v=2.3.11 --include-dependencies --no-rdoc --no-ri

#  mysql -u root -p
mysql> create database redmine;
mysql> grant all on redmine.* to redmine identified by '********';

#  wget http://rubyforge.org/frs/download.php/75097/redmine-1.2.1.tar.gz
#  tar xvfz redmine-1.2.1.tar.gz
#  mv redmine-1.2.1 /var/www/
#  cd /var/www/
#  ln -sfn redmine-1.2.1/ redmine
#  chown -R apache:apache redmine-1.2.1/
#  cd redmine
#  cp -a config/database.yml.example config/database.yml
#  vi config/database.yml
#  cp -a config/configuration.yml.example config/configuration.yml
#  vi config/configuration.yml
#  rake generate_session_store
#  rake db:migrate RAILS_ENV=production

#  gem install passenger --no-rdoc --no-ri
#  passenger-install-apache2-module
#  vi /etc/httpd/conf.d/passenger.conf

migrateでエラーが出た場合

# rake db:migrate RAILS_ENV=production
(in /var/www/redmine-1.2.1)
NOTE: Gem.source_index is deprecated, use Specification. It will be removed on or after 2011-11-01.
Gem.source_index called from /var/www/redmine-1.2.1/config/../vendor/rails/railties/lib/rails/gem_dependency.rb:21.
NOTE: Gem::SourceIndex#refresh! is deprecated with no replacement. It will be removed on or after 2011-11-01.
Gem::SourceIndex#refresh! called from /var/www/redmine-1.2.1/config/../vendor/rails/railties/lib/rails/vendor_gem_source_index.rb:34.
NOTE: Gem::SourceIndex#load_gems_in is deprecated with no replacement. It will be removed on or after 2011-11-01.
Gem::SourceIndex#load_gems_in called from /usr/local/lib/ruby/site_ruby/1.8/rubygems/source_index.rb:322.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from /usr/local/lib/ruby/site_ruby/1.8/rubygems/source_index.rb:127.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from /usr/local/lib/ruby/site_ruby/1.8/rubygems/source_index.rb:127.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from /usr/local/lib/ruby/site_ruby/1.8/rubygems/source_index.rb:127.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from /usr/local/lib/ruby/site_ruby/1.8/rubygems/source_index.rb:127.
NOTE: Gem::SourceIndex#initialize is deprecated with no replacement. It will be removed on or after 2011-11-01.
Gem::SourceIndex#initialize called from /var/www/redmine-1.2.1/config/../vendor/rails/railties/lib/rails/vendor_gem_source_index.rb:100.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from /usr/local/lib/ruby/site_ruby/1.8/rubygems/source_index.rb:91.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from /usr/local/lib/ruby/site_ruby/1.8/rubygems/source_index.rb:91.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from /usr/local/lib/ruby/site_ruby/1.8/rubygems/source_index.rb:91.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from /usr/local/lib/ruby/site_ruby/1.8/rubygems/source_index.rb:91.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from /usr/local/lib/ruby/site_ruby/1.8/rubygems/source_index.rb:91.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from /usr/local/lib/ruby/site_ruby/1.8/rubygems/source_index.rb:91.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from /usr/local/lib/ruby/site_ruby/1.8/rubygems/source_index.rb:91.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from /usr/local/lib/ruby/site_ruby/1.8/rubygems/source_index.rb:91.
rake aborted!
undefined method `name' for "i18n":String

(See full trace by running task with --trace)
#  gem update --system 1.6.2

gemが新しいとおせっかいなアラートが出るので、バージョンを落とす。

Pocket


So, what do you think ?