:::: MENU ::::

Trac0.10にWiki Include Pluginを入れる

Pocket

インストール方法

0.11用だけどgenshiも使ってないし、そのまま入れても使えるだろうと思って入れたら使えた。

# cd /usr/local/src/tracplugins
# mkdir wikiincludeplugin-0.11
# svn co http://trac-hacks.org/svn/wikiincludeplugin/0.11/ ./wikiincludeplugin-0.11
# cd wikiincludeplugin-0.11
# python setup.py bdist_egg

できたeggファイルを各tracのpluginフォルダに入れるだけ

trac.iniの設定

# vi ./conf/trac.ini
[components]
wikiinclude.* = enabled

wikiでの書き方

# Fooページをincludeする
[[WikiInclude(Foo)]]

# これは動かなかった。。。見たところ複数ページの読み込みっぽいけど。
[[WikiInclude(Foo|Argument1|Argument2..|ArgumentN)]]

# wikiのバージョン指定でincludeする
[[WikiInclude(Specification?version=7)]]
Pocket


So, what do you think ?